ラズベリーパイの古いOS(Wheezy)でapt-get updateをしたい【2022年5月】

スポンサーリンク
ラズベリーパイB Raspberry Pi

初代ラズパイ(Raspberry Pi B)のパッケージリストを最新にアップデートしようとしたら、以前の設定ではできなくなっていた。以下サイトを参考にして現時点(2022年5月)でもアップデートできるようになった。

サポートがとっくに終了しているRaspbian wheezyをまだ使うための設定(2020年)-apt、collabora.listの変更- | Analogfeeder

ラズパイの古いOS(Wheezy)のパッケージリストを最新にするための設定

まずはパッケージリストを参照するURLの書き換えを行うため、以下ファイルを開く。

sudo nano /etc/apt/sources.list

もとから記述されているURLは#でコメントアウトするか削除して、以下の1行を追加する。

deb http://legacy.raspbian.org/raspbian/ wheezy main contrib non-free rpi

先ほど紹介したサイトによると現在は、http://legacy.raspbian.org/raspbian/dists/wheezy/ にWheezyのファイルは移動されているとこのこと。

以上でWheezyでも sudo apt-get update ができるようになる。

sudo apt-get update時に警告がでて気になる場合は…

一応上記設定変更でパッケージリストを最新にアップデートできるようになった。しかし、わたしの場合、警告文が表示された。

アップデート時のイメージ(実際の警告文は赤色表示されません)

pi@raspberrypi ~ $ sudo apt-get update
ヒット http://legacy.raspbian.org wheezy Release.gpg
ヒット http://legacy.raspbian.org wheezy Release
ヒット http://legacy.raspbian.org wheezy/main armhf Packages
ヒット http://legacy.raspbian.org wheezy/contrib armhf Packages
ヒット http://legacy.raspbian.org wheezy/non-free armhf Packages
ヒット http://legacy.raspbian.org wheezy/rpi armhf Packages
無視 http://legacy.raspbian.org wheezy/contrib Translation-ja_JP
無視 http://legacy.raspbian.org wheezy/contrib Translation-ja
無視 http://legacy.raspbian.org wheezy/contrib Translation-en
無視 http://legacy.raspbian.org wheezy/main Translation-ja_JP
無視 http://legacy.raspbian.org wheezy/main Translation-ja
無視 http://legacy.raspbian.org wheezy/main Translation-en
無視 http://legacy.raspbian.org wheezy/non-free Translation-ja_JP
無視 http://legacy.raspbian.org wheezy/non-free Translation-ja
無視 http://legacy.raspbian.org wheezy/non-free Translation-en
無視 http://legacy.raspbian.org wheezy/rpi Translation-ja_JP
無視 http://legacy.raspbian.org wheezy/rpi Translation-ja
無視 http://legacy.raspbian.org wheezy/rpi Translation-en
パッケージリストを読み込んでいます... 完了
W: Duplicate sources.list entry http://legacy.raspbian.org/raspbian/ wheezy/main armhf Packages (/var/lib/apt/lists/legacy.raspbian.org_raspbian_dists_wheezy_main_binary-armhf_Packages)
W: Duplicate sources.list entry http://legacy.raspbian.org/raspbian/ wheezy/contrib armhf Packages (/var/lib/apt/lists/legacy.raspbian.org_raspbian_dists_wheezy_contrib_binary-armhf_Packages)
W: Duplicate sources.list entry http://legacy.raspbian.org/raspbian/ wheezy/non-free armhf Packages (/var/lib/apt/lists/legacy.raspbian.org_raspbian_dists_wheezy_non-free_binary-armhf_Packages)
W: Duplicate sources.list entry http://legacy.raspbian.org/raspbian/ wheezy/rpi armhf Packages (/var/lib/apt/lists/legacy.raspbian.org_raspbian_dists_wheezy_rpi_binary-armhf_Packages)
W: これらの問題を解決するためには apt-get update を実行する必要があるかもしれま せん

pi@raspberrypi ~ $ 

このままでもアップデートに支障はないが、警告文が気持ち悪いので /etc/apt/sources.list.d/ フォルダにあるサードパーティ製の設定ファイルを全て別名に変更してアップデート時に参照しないようにした。

以下コマンドでまずはファイル名を確認

ls /etc/apt/sources.list.d

わたしの場合、~.listファイルが3つ存在していた。

pi@raspberrypi ~ $ ls /etc/apt/sources.list.d
collabora.list raspi.list walfram.list

ちなみにsouces.list.dに存在する~.listファイルには、/etc/apt/sources.list に記述されていたようなURLが記述されている。ただし、どれも古いURLのため現在は意味がない。

そこで/etc/sources.list.d/ フォルダにある~.listファイルを全て別名にするか、削除する。(記述されているURLを#でコメントアウトすれば問題ないのでは?と思いやってみたが、ファイルが存在していると警告文がでるようだ)

わたしは以下のようにsources.list.dフォルダに移動して、mvコマンドで3つともファイル名を別名で保存した。

pi@raspberrypi ~ $ cd /etc/apt/sources.list.d
pi@raspberrypi /etc/apt/sources.list.d $ sudo mv collabora.list collabora.list.s
ave
pi@raspberrypi /etc/apt/sources.list.d $ sudo mv raspi.list raspi.list.save
pi@raspberrypi /etc/apt/sources.list.d $ sudo mv walfram.list walfram.list.save

再度、パッケージリストを更新してみる。

sudo apt-get update

警告文は表示されなくなった。

pi@raspberrypi ~ $ sudo apt-get update
ヒット http://legacy.raspbian.org wheezy Release.gpg
ヒット http://legacy.raspbian.org wheezy Release
ヒット http://legacy.raspbian.org wheezy/main armhf Packages
ヒット http://legacy.raspbian.org wheezy/contrib armhf Packages
ヒット http://legacy.raspbian.org wheezy/non-free armhf Packages
ヒット http://legacy.raspbian.org wheezy/rpi armhf Packages
無視 http://legacy.raspbian.org wheezy/contrib Translation-ja_JP
無視 http://legacy.raspbian.org wheezy/contrib Translation-ja
無視 http://legacy.raspbian.org wheezy/contrib Translation-en
無視 http://legacy.raspbian.org wheezy/main Translation-ja_JP
無視 http://legacy.raspbian.org wheezy/main Translation-ja
無視 http://legacy.raspbian.org wheezy/main Translation-en
無視 http://legacy.raspbian.org wheezy/non-free Translation-ja_JP
無視 http://legacy.raspbian.org wheezy/non-free Translation-ja
無視 http://legacy.raspbian.org wheezy/non-free Translation-en
無視 http://legacy.raspbian.org wheezy/rpi Translation-ja_JP
無視 http://legacy.raspbian.org wheezy/rpi Translation-ja
無視 http://legacy.raspbian.org wheezy/rpi Translation-en
パッケージリストを読み込んでいます... 完了
pi@raspberrypi ~ $

以上、まだまだラズパイの古いOSのWheezyは健在です。

コメント

タイトルとURLをコピーしました